| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|---|---|
| actionpack | ≥ 5.2.0, < 5.2.7.1≥ 6.0.0, < 6.0.4.8≥ 6.1.0, < 6.1.5.1≥ 7.0.0, < 7.0.2.4 | 5.2.7.16.0.4.86.1.5.17.0.2.4 |
| actionpack | ≥ 5.2.0, < 5.2.7.1≥ 6.0.0, < 6.0.4.8≥ 6.1.0, < 6.1.5.1≥ 7.0.0, < 7.0.2.4 | 5.2.7.16.0.4.86.1.5.17.0.2.4 |
There is a possible XSS vulnerability in Rails / Action Pack. This vulnerability has been assigned the CVE identifier CVE-2022-22577.
Versions Affected: >= 5.2.0 Not affected: < 5.2.0 Fixed Versions: 7.0.2.4, 6.1.5.1, 6.0.4.8, 5.2.7.1
CSP headers were only sent along with responses that Rails considered as "HTML" responses. This left API requests without CSP headers, which could possibly expose users to XSS attacks.
The FIXED releases are available at the normal locations.
Set a CSP for your API responses manually.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí