Tóm tắt nhanh
- CVE-2022-23505 là lỗ hổng mức CAO (CVSS 7.5) ảnh hưởng passport-wsfed-saml2 (auth0), passport-wsfed-saml2.
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 0.80%, cao hơn 56.6% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 4.6.3 hoặc mới hơn.
Mô tả
Overview
A remote attacker can bypass WSFed authentication on a website using passport-wsfed-saml2. A successful attack requires that the attacker is in possession of an arbitrary IDP signed WSFed assertion. Depending on the IDP used, fully unauthenticated attacks (e.g without access to a valid user) might also be feasible if generation of a signed message can be triggered.
Am I affected?
You are affected if you are using WSFed protocol with the passport-wsfed-saml2 library versions < 4.6.3.
SAML2 protocol is not affected.
How do I fix it?
Upgrade the library to version 4.6.3.
Will the fix impact my users?
No, the fix will not impact your users.
Mô tả của NVD
Passport-wsfed-saml2 is a ws-federation protocol and SAML2 tokens authentication provider for Passport. In versions prior to 4.6.3, a remote attacker may be able to bypass WSFed authentication on a website using passport-wsfed-saml2. A successful attack requires that the attacker is in possession of an arbitrary IDP signed assertion. Depending on the IDP used, fully unauthenticated attacks (e.g without access to a valid user) might also be feasible if generation of a signed message can be triggered. This issue is patched in version 4.6.3. Use of SAML2 authentication instead of WSFed is a workaround.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí