Tóm tắt nhanh
- CVE-2022-23515 là lỗ hổng mức TRUNG BÌNH (CVSS 6.1) ảnh hưởng loofah, loofah (loofah project).
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 0.86%, cao hơn 58.5% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 2.19.1 hoặc mới hơn.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| loofah RubyGems | ≥ 2.1.0, < 2.19.1
| 2.19.1
|
| loofah | ≥ 2.1.0, < 2.19.1
| 2.19.1
|
Mô tả
Summary
Loofah >= 2.1.0, < 2.19.1 is vulnerable to cross-site scripting via the image/svg+xml media type in data URIs.
Mitigation
Upgrade to Loofah >= 2.19.1.
Severity
The Loofah maintainers have evaluated this as Medium Severity 6.1.
References
Credit
This vulnerability was responsibly reported by Maciej Piechota (@haqpl).
Mô tả của NVD
Loofah is a general library for manipulating and transforming HTML/XML documents and fragments, built on top of Nokogiri. Loofah >= 2.1.0, < 2.19.1 is vulnerable to cross-site scripting via the image/svg+xml media type in data URIs. This issue is patched in version 2.19.1.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí