Tóm tắt nhanh
- CVE-2022-23516 là lỗ hổng mức CAO (CVSS 7.5) ảnh hưởng loofah, loofah (loofah project).
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 1.2%, cao hơn 67.4% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 2.19.1 hoặc mới hơn.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| loofah RubyGems | ≥ 2.2.0, < 2.19.1
| 2.19.1
|
| loofah | ≥ 2.2.0, < 2.19.1
| 2.19.1
|
Mô tả
Summary
Loofah >= 2.2.0, < 2.19.1 uses recursion for sanitizing CDATA sections, making it susceptible to stack exhaustion and raising a SystemStackError exception. This may lead to a denial of service through CPU resource consumption.
Mitigation
Upgrade to Loofah >= 2.19.1.
Users who are unable to upgrade may be able to mitigate this vulnerability by limiting the length of the strings that are sanitized.
Severity
The Loofah maintainers have evaluated this as High Severity 7.5 (CVSS3.1).
References
Mô tả của NVD
Loofah is a general library for manipulating and transforming HTML/XML documents and fragments, built on top of Nokogiri. Loofah >= 2.2.0, < 2.19.1 uses recursion for sanitizing CDATA sections, making it susceptible to stack exhaustion and raising a SystemStackError exception. This may lead to a denial of service through CPU resource consumption. This issue is patched in version 2.19.1. Users who are unable to upgrade may be able to mitigate this vulnerability by limiting the length of the strings that are sanitized.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí