Tóm tắt nhanh
- CVE-2022-23915 là lỗ hổng mức CAO (CVSS 8.8) ảnh hưởng weblate, weblate (weblate).
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 3.1%, cao hơn 87.8% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 4.11.1 hoặc mới hơn.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| weblate PyPI | < 4.11.1
| 4.11.1
|
| weblate | < 4.11.1
| 4.11.1
|
Mô tả
Impact
Weblate didn't correctly sanitize some arguments passed to Git and Mercurial, which allowed changing their behavior in an unintended way.
Patches
The issues were fixed in the 4.11.1 release. The following commits are addressing it:
- 35d59f1f040541c358cece0a8d4a63183ca919b8
- d83672a3e7415da1490334e2c9431e5da1966842
Workarounds
Instances in which untrusted users cannot create new components are not affected.
References
For more information
If you have any questions or comments about this advisory:
Mô tả của NVD
The package weblate from 0 and before 4.11.1 are vulnerable to Remote Code Execution (RCE) via argument injection when using git or mercurial repositories. Authenticated users, can change the behavior of the application in an unintended way, leading to command execution.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí