Tóm tắt nhanh
- CVE-2022-24709 là lỗ hổng mức TRUNG BÌNH (CVSS 6.1) ảnh hưởng awsui/components-react (amazon), @awsui/components-react.
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 0.69%, cao hơn 52.9% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 3.0.367 hoặc mới hơn.
Mô tả
Impact
Components could potentially allow cross-site scripting (XSS) in certain circumstances. These components could render content without adequate neutralization.
Patches
Fixed in 3.0.367.
Mô tả của NVD
@awsui/components-react is the main AWS UI package which contains React components, with TypeScript definitions designed for user interface development. Multiple components in versions before 3.0.367 have been found to not properly neutralize user input and may allow for javascript injection. Users are advised to upgrade to version 3.0.367 or later. There are no known workarounds for this issue.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí