Tóm tắt nhanh
- CVE-2022-24711 là lỗ hổng mức NGHIÊM TRỌNG (CVSS 9.8) ảnh hưởng codeigniter4/framework, codeigniter (codeigniter).
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 1.2%, cao hơn 67.5% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 4.1.9 hoặc mới hơn.
Mô tả
Impact
This vulnerability allows attackers to execute CLI routes via HTTP request.
Patches
Upgrade to v4.1.9 or later.
Workarounds
None.
For more information
If you have any questions or comments about this advisory:
Mô tả của NVD
CodeIgniter4 is the 4.x branch of CodeIgniter, a PHP full-stack web framework. Prior to version 4.1.9, an improper input validation vulnerability allows attackers to execute CLI routes via HTTP request. Version 4.1.9 contains a patch. There are currently no known workarounds for this vulnerability.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí