Tóm tắt nhanh
- CVE-2022-24758 là lỗ hổng mức CAO (CVSS 7.5) ảnh hưởng notebook, notebook (jupyter).
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 1.1%, cao hơn 65.8% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 6.4.10 hoặc mới hơn.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| notebook PyPI | < 6.4.10
| 6.4.10
|
| notebook | < 6.4.10
| 6.4.10
|
Mô tả
Anytime a 5xx error is triggered, the auth cookie and other header values are recorded in Jupyter server logs by default. Considering these logs do not require root access, an attacker can monitor these logs, steal sensitive auth/cookie information, and gain access to the Jupyter server.
Upgrade to notebook version 6.4.10
For more information
If you have any questions or comments about this advisory, or vulnerabilities to report, please email our security list [email protected].
Credit: @3coins for reporting. Thank you!
Mô tả của NVD
The Jupyter notebook is a web-based notebook environment for interactive computing. Prior to version 6.4.9, unauthorized actors can access sensitive information from server logs. Anytime a 5xx error is triggered, the auth cookie and other header values are recorded in Jupyter server logs by default. Considering these logs do not require root access, an attacker can monitor these logs, steal sensitive auth/cookie information, and gain access to the Jupyter server. Jupyter notebook version 6.4.x contains a patch for this issue. There are currently no known workarounds.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí