Tóm tắt nhanh
- CVE-2022-29230 là lỗ hổng mức TRUNG BÌNH (CVSS 5.4) ảnh hưởng hydrogen (shopify), @shopify/hydrogen.
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 0.83%, cao hơn 57.6% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 0.19.0 hoặc mới hơn.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| hydrogen | ≥ 0.10.0, < 0.19.0
| 0.19.0
|
| @shopify/hydrogen npm | ≥ 0.10.0, < 0.19.0
| 0.19.0
|
Mô tả
Impact
There is a potential Cross-Site Scripting (XSS) vulnerability where an arbitrary user is able to execute scripts on pages that are built with Hydrogen. This affects all versions of Hydrogen starting from version 0.10.0 to 0.18.0. This vulnerability is exploitable in applications whose hydrating data is user controlled.
Patches
All Hydrogen users should upgrade their project to v0.19.0.
Workarounds
There is no current workaround, and users should update as soon as possible.
Additionally, the Content Security Policy is not an effective mitigation for this vulnerability.
References
GitHub: Hydrogen v0.19.0
Fix PR: https://github.com/Shopify/hydrogen/pull/1272
For more information
If you have any questions or comments about this advisory:
Mô tả của NVD
Hydrogen is a React-based framework for building dynamic, Shopify-powered custom storefronts. There is a potential Cross-Site Scripting (XSS) vulnerability where an arbitrary user is able to execute scripts on pages that are built with Hydrogen. This affects all versions of Hydrogen starting from version 0.10.0 to 0.18.0. This vulnerability is exploitable in applications whose hydrating data is user controlled. All Hydrogen users should upgrade their project to version 0.19.0. There is no current workaround, and users should update as soon as possible. Additionally, the Content Security Policy is not an effective mitigation for this vulnerability.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí