Tóm tắt nhanh
- CVE-2022-31000 là lỗ hổng mức TRUNG BÌNH (CVSS 4.3) ảnh hưởng solidus_backend, solidus (nebulab).
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 0.41%, cao hơn 35.7% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 3.0.6, 3.1.6, 2.11.16, 3.0.5 hoặc mới hơn.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| solidus_backend RubyGems | ≥ 3.0.0, < 3.0.6≥ 3.1.0, < 3.1.6< 2.11.16
| 3.0.63.1.62.11.16
|
| solidus | ≥ 3.0.0, < 3.0.5≥ 3.1.0, < 3.1.6< 2.11.16
| 3.0.53.1.62.11.16
|
Mô tả
Impact
CSRF vulnerability allowing attackers to change the state of an order's adjustments if they hold its number, and the execution happens on a store administrator's computer.
Reproduction steps:
- Take an order's number.
- Log in as an administrator.
- Visit that order's adjustments section (Orders -> {Click on number} -> Adjustments) and check that its adjustments are finalized (closed padlock under the State column).
- On another tab, visit
{your_site_url}/admin/orders/{order_number}/adjustments/unfinalize.
- Notice how the adjustments are unfinalized (open padlock), even if the previous was a
GET request which could have been linked from any other site.
- Visit
{your_site_url}/admin/orders/{order_number}/adjustments/finalize.
- Notice how the adjustments are again finalized.
That happened because both routes were handled as GET requests, which are skipped by Rails anti-forgery protection.
Patches
Users should upgrade to solidus_backend v3.1.6, v3.0.6, or v2.11.16, depending on the major and minor versions in use.
References
For more information
If you have any questions or comments about this advisory:
Mô tả của NVD
solidus_backend is the admin interface for the Solidus e-commerce framework. Versions prior to 3.1.6, 3.0.6, and 2.11.16 contain a cross-site request forgery (CSRF) vulnerability. The vulnerability allows attackers to change the state of an order's adjustments if they hold its number, and the execution happens on a store administrator's computer. Users should upgrade to solidus_backend 3.1.6, 3.0.6, or 2.11.16 to receive a patch.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí