Tóm tắt nhanh
- CVE-2022-31026 là lỗ hổng mức CAO (CVSS 7.5) ảnh hưởng trilogy, trilogy (trilogy project).
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 1.1%, cao hơn 65.7% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 2.1.1 hoặc mới hơn.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| trilogy RubyGems | < 2.1.1
| 2.1.1
|
| trilogy | < 2.1.1
| 2.1.1
|
Mô tả
Impact
When authenticating, a malicious server could return a specially crafted authentication packet, causing the client to read and return up to 12 bytes of data from an uninitialized variable in stack memory.
Patches
Users of the trilogy gem should upgrade to version 2.1.1
Workarounds
This issue can be avoided by only connecting to trusted servers.
Acknowledgements
We would like to thank Sergei Volokitin for reporting this vulnerability
For more information
If you have any questions or comments about this advisory:
Mô tả của NVD
Trilogy is a client library for MySQL. When authenticating, a malicious server could return a specially crafted authentication packet, causing the client to read and return up to 12 bytes of data from an uninitialized variable in stack memory. Users of the trilogy gem should upgrade to version 2.1.1 This issue can be avoided by only connecting to trusted servers.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí