Tóm tắt nhanh
- CVE-2022-31124 là lỗ hổng mức TRUNG BÌNH (CVSS 6.5) ảnh hưởng openssh-key-parser, openssh key parser (openssh key parser project).
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 1.3%, cao hơn 71.3% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 0.0.6 hoặc mới hơn.
Mô tả
Impact
If a field of a key is shorter than it is declared to be, the parser raises an error with a message containing the raw field value. An attacker able to modify the declared length of a key's sensitive field can thus expose the raw value of that field.
Patches
Upgrade to version 0.0.6, which no longer includes the raw field value in the error message.
Workarounds
N/A
References
N/A
For more information
If you have any questions or comments about this advisory:
Mô tả của NVD
openssh_key_parser is an open source Python package providing utilities to parse and pack OpenSSH private and public key files. In versions prior to 0.0.6 if a field of a key is shorter than it is declared to be, the parser raises an error with a message containing the raw field value. An attacker able to modify the declared length of a key's sensitive field can thus expose the raw value of that field. Users are advised to upgrade to version 0.0.6, which no longer includes the raw field value in the error message. There are no known workarounds for this issue.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí