Tóm tắt nhanh
- CVE-2022-31147 là lỗ hổng mức CAO (CVSS 7.5) ảnh hưởng jquery validation (jqueryvalidation), jquery-validation.
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 2.2%, cao hơn 82.9% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 1.19.5 hoặc mới hơn.
Mô tả
Summary
Incomplete fix of CVE-2021-43306: An exponential ReDoS (Regular Expression Denial of Service) can be triggered in the jquery-validation npm package, when an attacker is able to supply arbitrary input to the url2 method.
Mô tả của NVD
The jQuery Validation Plugin (jquery-validation) provides drop-in validation for forms. Versions of jquery-validation prior to 1.19.5 are vulnerable to regular expression denial of service (ReDoS) when an attacker is able to supply arbitrary input to the url2 method. This is due to an incomplete fix for CVE-2021-43306. Users should upgrade to version 1.19.5 to receive a patch.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí