| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|---|---|
| github.com/rancher/wrangler | ≥ 0.8.0, < 0.8.5-security1≥ 0.8.6, < 0.8.11≥ 1.0.0, < 1.0.1< 0.7.4-security1 | 0.8.5-security10.8.111.0.10.7.4-security1 |
| wrangler | = 1.0.0≥ 0.8.0, < 0.8.5< 0.7.4 | 0.8.50.7.4 |
A command injection vulnerability was discovered in Wrangler's Git package affecting versions up to and including v1.0.0.
Wrangler's Git package uses the underlying Git binary present in the host OS or container image to execute Git operations. Specially crafted commands can be passed to Wrangler that will change their behavior and cause confusion when executed through Git, resulting in command injection in the underlying host.
A workaround is to sanitize input passed to the Git package to remove potential unsafe and ambiguous characters. Otherwise, the best course of action is to update to a patched Wrangler version.
Patched versions include v1.0.1 and later and the backported tags - v0.7.4-security1, v0.8.5-security1 and v0.8.11.
If you have any questions or comments about this advisory:
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí