Tóm tắt nhanh
- CVE-2022-36024 là lỗ hổng mức TRUNG BÌNH (CVSS 6.5) ảnh hưởng py-cord, pycord (pycord development).
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 0.82%, cao hơn 57.5% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 2.0.1 hoặc mới hơn.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| py-cord PyPI | ≥ 2.0.0, < 2.0.1
| 2.0.1
|
| pycord | = 2.0.0
| Chưa có bản vá |
Mô tả
Impact
py-cord is a an API wrapper for Discord written in Python. Bots using py-cord version 2.0.0 are vulnerable to remote shutdown if they are added to the server with the application.commands scope without the bot scope. Currently, it appears that all public bots that use slash commands are affected.
Patches
This issue has been patched in version 2.0.1.
Workarounds
There are currently no recommended workarounds - please upgrade to a patched version.
References
https://github.com/Pycord-Development/pycord/pull/1568
For more information
If you have any questions or comments about this advisory:
Mô tả của NVD
py-cord is a an API wrapper for Discord written in Python. Bots creating using py-cord version 2.0.0 are vulnerable to remote shutdown if they are added to the server with the `application.commands` scope without the `bot` scope. Currently, it appears that all public bots that use slash commands are affected. This issue has been patched in version 2.0.1. There are currently no recommended workarounds - please upgrade to a patched version.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí