Tóm tắt nhanh
- CVE-2022-39313 là lỗ hổng mức CAO (CVSS 7.5) ảnh hưởng parse-server (parseplatform), parse-server.
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 0.81%, cao hơn 57.0% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 5.2.8, 4.10.17 hoặc mới hơn.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| parse-server | ≥ 5.0.0, < 5.2.8< 4.10.17
| 5.2.84.10.17
|
| parse-server npm | ≥ 5.0.0, < 5.2.8< 4.10.17
| 5.2.84.10.17
|
Mô tả
Impact
Parse Server crashes when a file download request is received with an invalid byte range.
Patches
Improved parsing of the range parameter to properly handle invalid range requests.
Workarounds
None
References
Mô tả của NVD
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Versions prior to 4.10.17, and prior to 5.2.8 on the 5.x branch, crash when a file download request is received with an invalid byte range, resulting in a Denial of Service. This issue has been patched in versions 4.10.17, and 5.2.8. There are no known workarounds.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí