Tóm tắt nhanh
- CVE-2022-39379 là lỗ hổng mức NGHIÊM TRỌNG (CVSS 9.8) ảnh hưởng fluentd, fluentd (fluentd).
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 45.0%, cao hơn 98.8% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 1.15.3 hoặc mới hơn.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| fluentd RubyGems | ≥ 1.13.2, < 1.15.3
| 1.15.3
|
| fluentd | ≥ 1.13.2, < 1.15.3
| 1.15.3
|
Mô tả
Impact
A remote code execution (RCE) vulnerability in non-default configurations of Fluentd allows unauthenticated attackers to execute arbitrary code via specially crafted JSON payloads.
Fluentd setups are only affected if the environment variable FLUENT_OJ_OPTION_MODE is explicitly set to object.
Please note: The option FLUENT_OJ_OPTION_MODE was introduced in Fluentd version 1.13.2. Earlier versions of Fluentd are not affected by this vulnerability.
Patches
v1.15.3
Workarounds
Do not use FLUENT_OJ_OPTION_MODE=object.
References
Mô tả của NVD
Fluentd collects events from various data sources and writes them to files, RDBMS, NoSQL, IaaS, SaaS, Hadoop and so on. A remote code execution (RCE) vulnerability in non-default configurations of Fluentd allows unauthenticated attackers to execute arbitrary code via specially crafted JSON payloads. Fluentd setups are only affected if the environment variable `FLUENT_OJ_OPTION_MODE` is explicitly set to `object`. Please note: The option FLUENT_OJ_OPTION_MODE was introduced in Fluentd version 1.13.2. Earlier versions of Fluentd are not affected by this vulnerability. This issue was patched in version 1.15.3. As a workaround do not use `FLUENT_OJ_OPTION_MODE=object`.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí