| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|---|---|
| websocket | = 5.0.0≥ 6.0.0, < 7.1.1 | 7.1.1 |
| @fastify/websocket | ≥ 5.0.0, < 5.0.1≥ 6.0.0, < 7.1.1 | 5.0.17.1.1 |
| fastify-websocket | ≤ 4.3.0 |
Any application using @fastify/websocket could crash if a specific, malformed packet is sent.
All versions of fastify-websocket are also impacted. That module is deprecated, so it will not be patched.
This has been patched in v7.1.1 (fastify v4) and v5.0.1 (fastify v3).
No known workaround is available. However, it should be possible to attach the error handler manually. The recommended path is upgrading to the patched versions.
marcolanaro for finding and patching this vulnerability
If you have any questions or comments about this advisory:
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí