Tóm tắt nhanh
- CVE-2022-41957 là lỗ hổng mức CAO (CVSS 7.5) ảnh hưởng muhammara (muhammara project), hummus, muhammara.
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 1.1%, cao hơn 67.1% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 3.3.0, 2.6.2, 3.4.0 hoặc mới hơn.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| muhammara | ≥ 3.0.0, < 3.3.0< 2.6.2
| 3.3.02.6.2
|
| hummus npm | mọi phiên bản
| Chưa có bản vá |
| muhammara npm | ≥ 3.0.0, < 3.4.0< 2.6.2
| 3.4.02.6.2
|
Mô tả
Impact
The package muhammara before 2.6.2, from 3.0.0 and before 3.3.0; all versions of package hummus are vulnerable to Denial of Service (DoS) when supplied with a maliciously crafted PDF file to be parsed.
Patches
It has been patched in 3.4.0 and has been backported to 2.6.2
There is no patch for hummus, currently
Workarounds
Do not process files from untrusted sources or update.
Replace hummus with muhammara
References
https://github.com/julianhille/MuhammaraJS/pull/235
https://github.com/julianhille/MuhammaraJS/pull/238
Mô tả của NVD
Muhammara is a node module with c/cpp bindings to modify PDF with JavaScript for node or electron. The package muhammara before 2.6.2 and from 3.0.0 and before 3.3.0, as well as all versions of muhammara's predecessor package hummus, are vulnerable to Denial of Service (DoS) when supplied with a maliciously crafted PDF file to be parsed. The issue has been patched in muhammara version 3.4.0 and the fix has been backported to version 2.6.2. As a workaround, do not process files from untrusted sources. If using hummus, replace the package with muhammara.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí