Tóm tắt nhanh
- CVE-2022-46170 là lỗ hổng mức NGHIÊM TRỌNG (CVSS 9.8) ảnh hưởng codeigniter4/framework, codeigniter (codeigniter).
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 0.91%, cao hơn 60.1% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 4.2.11 hoặc mới hơn.
Mô tả
Impact
When an application uses (1) multiple session cookies (e.g., one for user pages and one for admin pages) and (2) a session handler is set to DatabaseHandler, MemcachedHandler, or RedisHandler, then if an attacker gets one session cookie (e.g., one for user pages), they may be able to access pages that require another session cookie (e.g., for admin pages).
Patches
Upgrade to version 4.2.11 or later.
Workarounds
- Use only one session cookie.
References
For more information
If you have any questions or comments about this advisory:
Mô tả của NVD
CodeIgniter is a PHP full-stack web framework. When an application uses (1) multiple session cookies (e.g., one for user pages and one for admin pages) and (2) a session handler is set to `DatabaseHandler`, `MemcachedHandler`, or `RedisHandler`, then if an attacker gets one session cookie (e.g., one for user pages), they may be able to access pages that require another session cookie (e.g., for admin pages). This issue has been patched, please upgrade to version 4.2.11 or later. As a workaround, use only one session cookie.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí