Tóm tắt nhanh
- CVE-2023-28447 là lỗ hổng mức TRUNG BÌNH (CVSS 6.1) ảnh hưởng smarty/smarty, smarty (smarty).
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 1.0%, cao hơn 63.3% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 4.3.1, 3.1.48 hoặc mới hơn.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| smarty/smarty Packagist | ≥ 4.0.0, < 4.3.1< 3.1.48
| 4.3.13.1.48
|
| smarty | ≥ 4.0.0, < 4.3.1< 3.1.48
| 4.3.13.1.48
|
Mô tả
Impact
An attacker could exploit this vulnerability to execute arbitrary JavaScript code in the context of the user's browser session. This may lead to unauthorized access to sensitive user data, manipulation of the web application's behavior, or unauthorized actions performed on behalf of the user.
Patches
Please upgrade to the most recent version of Smarty v3 or v4.
For more information
If you have any questions or comments about this advisory please open an issue in the Smarty repo
Mô tả của NVD
Smarty is a template engine for PHP. In affected versions smarty did not properly escape javascript code. An attacker could exploit this vulnerability to execute arbitrary JavaScript code in the context of the user's browser session. This may lead to unauthorized access to sensitive user data, manipulation of the web application's behavior, or unauthorized actions performed on behalf of the user. Users are advised to upgrade to either version 3.1.48 or to 4.3.1 to resolve this issue. There are no known workarounds for this vulnerability.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí