Tóm tắt nhanh
- CVE-2023-29197 là lỗ hổng mức CAO (CVSS 7.5) ảnh hưởng guzzlehttp/psr7, psr-7 (guzzlephp).
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 1.2%, cao hơn 68.6% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 2.4.5, 1.9.1 hoặc mới hơn.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| guzzlehttp/psr7 Packagist | ≥ 2.0.0, < 2.4.5< 1.9.1
| 2.4.51.9.1
|
| psr-7 | ≥ 2.0.0, < 2.4.5< 1.9.1
| 2.4.51.9.1
|
Mô tả
Impact
Improper header parsing. An attacker could sneak in a newline (\n) into both the header names and values. While the specification states that \r\n\r\n is used to terminate the header list, many servers in the wild will also accept \n\n.
Patches
The issue is patched in 1.9.1 and 2.4.5.
Workarounds
There are no known workarounds.
References
Mô tả của NVD
guzzlehttp/psr7 is a PSR-7 HTTP message library implementation in PHP. Affected versions are subject to improper header parsing. An attacker could sneak in a newline (\n) into both the header names and values. While the specification states that \r\n\r\n is used to terminate the header list, many servers in the wild will also accept \n\n. This is a follow-up to CVE-2022-24775 where the fix was incomplete. The issue has been patched in versions 1.9.1 and 2.4.5. There are no known workarounds for this vulnerability. Users are advised to upgrade.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí