| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|---|---|
| org.xwiki.platform:xwiki-platform-attachment-ui | ≥ 14.0-rc-1, < 14.4.8≥ 14.5, < 14.10.2≥ 3.0-rc-1, < 13.10.11 | 14.4.814.10.213.10.11 |
| xwiki | ≥ 14.0, < 14.4.8≥ 14.5, < 14.10.2< 13.10.11 | 14.4.814.10.213.10.11 |
A registered user can perform remote code execution leading to privilege escalation by injecting the proper code in the "property" field of an attachment selector, as a gadget of their own dashboard. Note that the vulnerability does not impact comments of a wiki.
The vulnerability has been patched in XWiki 13.10.11, 14.4.8, 14.10.2, 15.0-rc-1.
The problem can be worked around by applying following changes directly in XWiki.AttachmentSelector page: https://github.com/xwiki/xwiki-platform/commit/5e8725b4272cd3e5be09d3ca84273be2da6869c1.
If you have any questions or comments about this advisory:
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí