Tóm tắt nhanh
- CVE-2023-31143 là lỗ hổng mức NGHIÊM TRỌNG (CVSS 9.8) ảnh hưởng mage-ai, mage-ai (mage).
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 0.66%, cao hơn 51.8% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 0.8.72 hoặc mới hơn.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| mage-ai PyPI | ≥ 0.8.34, < 0.8.72
| 0.8.72
|
| mage-ai | ≥ 0.8.34, < 0.8.72
| 0.8.72
|
Mô tả
Impact
You may be impacted if you're using Mage with user authentication enabled. The terminal could be accessed by users who are not signed in or do not have editor permissions.
Patches
The vulnerability has been resolved in Mage version 0.8.72.
Mô tả của NVD
mage-ai is an open-source data pipeline tool for transforming and integrating data. Those who use Mage starting in version 0.8.34 and prior to 0.8.72 with user authentication enabled may be affected by a vulnerability. The terminal could be accessed by users who are not signed in or do not have editor permissions. Version 0.8.72 contains a fix for this issue.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí