Tóm tắt nhanh
- CVE-2023-32314 là lỗ hổng mức NGHIÊM TRỌNG (CVSS 10.0) ảnh hưởng vm2 (vm2 project), vm2.
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 8.1%, cao hơn 94.8% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 3.9.18 hoặc mới hơn.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| vm2 | < 3.9.18
| 3.9.18
|
| vm2 npm | < 3.9.18
| 3.9.18
|
Mô tả
A sandbox escape vulnerability exists in vm2 for versions up to 3.9.17. It abuses an unexpected creation of a host object based on the specification of Proxy.
Impact
A threat actor can bypass the sandbox protections to gain remote code execution rights on the host running the sandbox.
Patches
This vulnerability was patched in the release of version 3.9.18 of vm2.
Workarounds
None.
References
PoC - https://gist.github.com/arkark/e9f5cf5782dec8321095be3e52acf5ac
For more information
If you have any questions or comments about this advisory:
Thanks to @arkark (Takeshi Kaneko) of GMO Cybersecurity by Ierae, Inc. for disclosing this vulnerability.
Mô tả của NVD
vm2 is a sandbox that can run untrusted code with Node's built-in modules. A sandbox escape vulnerability exists in vm2 for versions up to and including 3.9.17. It abuses an unexpected creation of a host object based on the specification of `Proxy`. As a result a threat actor can bypass the sandbox protections to gain remote code execution rights on the host running the sandbox. This vulnerability was patched in the release of version `3.9.18` of `vm2`. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí