Tóm tắt nhanh
- CVE-2023-32325 là lỗ hổng mức TRUNG BÌNH (CVSS 6.1) ảnh hưởng posthog-js (posthog), posthog-js.
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 0.43%, cao hơn 37.3% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 1.57.2 hoặc mới hơn.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| posthog-js | < 1.57.2
| 1.57.2
|
| posthog-js npm | < 1.57.2
| 1.57.2
|
Mô tả
Impact
Potential for cross-site scripting in posthog-js.
Patches
The problem has been patched in posthog-js version 1.57.2.
Workarounds
- This isn't an issue for sites that have a Content Security Policy in place.
- Using the HTML tracking snippet on PostHog Cloud always guarantees the latest version of the library – in that case no action is required to upgrade to the patched version.
References
We will publish details of the vulnerability in 30 days as per our security policy.
Mô tả của NVD
PostHog-js is a library to interface with the PostHog analytics tool. Versions prior to 1.57.2 have the potential for cross-site scripting. Problem has been patched in 1.57.2. Users are advised to upgrade. Users unable to upgrade should ensure that their Content Security Policy is in place.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí