Tóm tắt nhanh
- CVE-2023-33197 là lỗ hổng mức TRUNG BÌNH (CVSS 5.4) ảnh hưởng craftcms/cms, craft cms (craftcms).
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 0.68%, cao hơn 52.4% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 4.4.6 hoặc mới hơn.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| craftcms/cms Packagist | ≥ 4.0.0-RC1, < 4.4.6
| 4.4.6
|
| craft cms | < 4.4.6
| 4.4.6
|
Mô tả
Summary
XSS can be triggered via the Update Asset Index utility
PoC
- Access setting tab
- Create new assets
- In assets name inject payload: "<script>alert(26)</script>
- Click Utilities tab
- Choose all volumes, or volume trigger xss
- Click Update asset indexes.
XSS will be triggered
Json response volumes name makes triggers the payload
"session":{"id":1,"indexedVolumes":{"1":"\"<script>alert(26)</script>"},
It’s run on every POST request in the utility.
Resolved in https://github.com/craftcms/cms/commit/8c2ad0bd313015b8ee42326af2848ee748f1d766
Mô tả của NVD
Craft is a CMS for creating custom digital experiences on the web. Cross-site scripting (XSS) can be triggered via the Update Asset Index utility. This issue has been patched in version 4.4.6.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí