Tóm tắt nhanh
- CVE-2023-3348 là lỗ hổng mức TRUNG BÌNH (CVSS 5.7) ảnh hưởng wrangler (cloudflare), wrangler.
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 0.82%, cao hơn 57.2% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 3.1.1, 2.20.1 hoặc mới hơn.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| wrangler | < 3.1.1
| 3.1.1
|
| wrangler npm | < 2.20.1
| 2.20.1
|
Mô tả
Impact
The Wrangler command line tool (<[email protected] or <[email protected]) was affected by a directory traversal vulnerability when running a local development server for Pages (wrangler pages dev command). This vulnerability enabled an attacker in the same network as the victim to connect to the local development server and access the victim's files present outside of the directory for the development server.
Patches
Wrangler2: Upgrade to v2.20.1 or higher.
Wrangler3: Upgrade to v3.1.1 or higher.
References
Workers SDK on Github
Wrangler docs
CVE-2023-3348
Mô tả của NVD
The Wrangler command line tool (<[email protected] or <[email protected]) was affected by a directory traversal vulnerability when running a local development server for Pages (wrangler pages dev command). This vulnerability enabled an attacker in the same network as the victim to connect to the local development server and access the victim's files present outside of the directory for the development server.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí