Tóm tắt nhanh
- CVE-2023-34090 là lỗ hổng mức CAO (CVSS 7.5) ảnh hưởng decidim, decidim-meetings, decidim (decidim).
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 1.3%, cao hơn 69.6% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 0.27.3 hoặc mới hơn.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| decidim RubyGems | ≥ 0.27.0, < 0.27.3
| 0.27.3
|
| decidim-meetings RubyGems | ≥ 0.27.0, < 0.27.3
| 0.27.3
|
| decidim | < 0.27.3
| 0.27.3
|
Mô tả
Note: added the actual report as a comment.
Summary
Decidim, a platform for digital citizen participation, uses a third-party library named Ransack for filtering certain database collections (e.g., public meetings). By default, this library allows filtering on all data attributes and associations. This allows an unauthenticated remote attacker to exfiltrate non-public data from the underlying database of a Decidim instance (e.g., exfiltrating data from the user table).
Impact
This issue may lead to Sensitive Data Disclosure.
Patches
The problem was patched in v0.27.3.
Workarounds
Disable or unpublish all meetings components from your application.
Mô tả của NVD
Decidim is a participatory democracy framework, written in Ruby on Rails, originally developed for the Barcelona City government online and offline participation website. Decidim uses a third-party library named Ransack for filtering certain database collections (e.g., public meetings). By default, this library allows filtering on all data attributes and associations. This allows an unauthenticated remote attacker to exfiltrate non-public data from the underlying database of a Decidim instance (e.g., exfiltrating data from the user table). This issue may lead to Sensitive Data Disclosure. The problem was patched in version 0.27.3.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí