Tóm tắt nhanh
- CVE-2023-48699 là lỗ hổng mức NGHIÊM TRỌNG (CVSS 9.8) ảnh hưởng fastbots, fastbots (ubertidavide).
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 0.74%, cao hơn 55.0% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 0.1.5 hoặc mới hơn.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| fastbots PyPI | < 0.1.5
| 0.1.5
|
| fastbots | < 0.1.5
| 0.1.5
|
Mô tả
Impact
An attacker could modify the locators.ini locator file with python code that without proper validation it's executed and it could lead to rce. The vulnerability is in the function def locator(self, locator_name: str) in page.py. The vulnerable code that load and execute directly from the file without validation it's:
return eval(self._bot.locator(self._page_name, locator_name))
Patches
In order to mitigate this issue it's important to upgrade to fastbots version 0.1.5 or above.
References
Merge that fix also this issue
Mô tả của NVD
fastbots is a library for fast bot and scraper development using selenium and the Page Object Model (POM) design. Prior to version 0.1.5, an attacker could modify the locators.ini locator file with python code that without proper validation it's executed and it could lead to rce. The vulnerability is in the function `def __locator__(self, locator_name: str)` in `page.py`. In order to mitigate this issue, upgrade to fastbots version 0.1.5 or above.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí