Tóm tắt nhanh
- CVE-2023-49920 là lỗ hổng mức TRUNG BÌNH (CVSS 6.5) ảnh hưởng apache-airflow, airflow (apache).
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 1.0%, cao hơn 63.8% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 2.8.0, 2.8.0b1 hoặc mới hơn.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| apache-airflow PyPI | ≥ 2.7.0, < 2.8.0≥ 2.7.0, < 2.8.0b1
| 2.8.02.8.0b1
|
| airflow | ≥ 2.7.0, ≤ 2.7.3
| Chưa có bản vá |
Mô tả
Apache Airflow, version 2.7.0 through 2.7.3, has a vulnerability that allows an attacker to trigger a DAG in a GET request without CSRF validation. As a result, it was possible for a malicious website opened in the same browser - by the user who also had Airflow UI opened - to trigger the execution of DAGs without the user's consent.
Users are advised to upgrade to version 2.8.0 or later which is not affected
Mô tả của NVD
Apache Airflow, version 2.7.0 through 2.7.3, has a vulnerability that allows an attacker to trigger a DAG in a GET request without CSRF validation. As a result, it was possible for a malicious website opened in the same browser - by the user who also had Airflow UI opened - to trigger the execution of DAGs without the user's consent.
Users are advised to upgrade to version 2.8.0 or later which is not affected
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí