Tóm tắt nhanh
- CVE-2024-2035 là lỗ hổng mức TRUNG BÌNH (CVSS 6.5) ảnh hưởng zenml, zenml (zenml).
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 0.63%, cao hơn 50.1% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 0.56.2 hoặc mới hơn.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| zenml PyPI | < 0.56.2
| 0.56.2
|
| zenml | < 0.56.2
| 0.56.2
|
Mô tả
An improper authorization vulnerability exists in the zenml-io/zenml repository, specifically within the API PUT /api/v1/users/id endpoint. This vulnerability allows any authenticated user to modify the information of other users, including changing the active status of user accounts to false, effectively deactivating them. This issue affects version 0.55.3 and was fixed in version 0.56.2. The impact of this vulnerability is significant as it allows for the deactivation of admin accounts, potentially disrupting the functionality and security of the application.
Mô tả của NVD
An improper authorization vulnerability exists in the zenml-io/zenml repository, specifically within the API PUT /api/v1/users/id endpoint. This vulnerability allows any authenticated user to modify the information of other users, including changing the `active` status of user accounts to false, effectively deactivating them. This issue affects version 0.55.3 and was fixed in version 0.56.2. The impact of this vulnerability is significant as it allows for the deactivation of admin accounts, potentially disrupting the functionality and security of the application.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí