Tóm tắt nhanh
- CVE-2024-21647 là lỗ hổng mức CAO (CVSS 7.5) ảnh hưởng puma, puma (puma).
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 0.96%, cao hơn 61.5% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 6.4.2, 5.6.8 hoặc mới hơn.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| puma RubyGems | ≥ 6.0.0, < 6.4.2< 5.6.8
| 6.4.25.6.8
|
| puma | ≥ 6.0.0, < 6.4.2< 5.6.8
| 6.4.25.6.8
|
Mô tả
Impact
Prior to versions 6.4.2 and 5.6.8, puma exhibited dangerous behavior when parsing chunked transfer encoding bodies.
Fixed versions limit the size of chunk extensions. Without this limit, an attacker could cause unbounded resource (CPU, network bandwidth) consumption.
Patches
The vulnerability has been fixed in 6.4.2 and 5.6.8.
Workarounds
No known workarounds.
References
Mô tả của NVD
Puma is a web server for Ruby/Rack applications built for parallelism. Prior to version 6.4.2, puma exhibited incorrect behavior when parsing chunked transfer encoding bodies in a way that allowed HTTP request smuggling. Fixed versions limits the size of chunk extensions. Without this limit, an attacker could cause unbounded resource (CPU, network bandwidth) consumption. This vulnerability has been fixed in versions 6.4.2 and 5.6.8.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí