Tóm tắt nhanh
- CVE-2024-22207 là lỗ hổng mức TRUNG BÌNH (CVSS 5.3) ảnh hưởng swagger ui (smartbear), @fastify/swagger-ui.
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 2.3%, cao hơn 83.2% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 2.1.0 hoặc mới hơn.
Mô tả
Impact
The default configuration of @fastify/swagger-ui without baseDir set will lead to all files in the module's directory being exposed via http routes served by the module.
Patches
Update to v2.1.0
Workarounds
Use the baseDir option
References
HackerOne report
.
Mô tả của NVD
fastify-swagger-ui is a Fastify plugin for serving Swagger UI. Prior to 2.1.0, the default configuration of `@fastify/swagger-ui` without `baseDir` set will lead to all files in the module's directory being exposed via http routes served by the module. The vulnerability is fixed in v2.1.0. Setting the `baseDir` option can also work around this vulnerability.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí