Tóm tắt nhanh
- CVE-2024-23828 là lỗ hổng mức CAO (CVSS 8.8) ảnh hưởng github.com/0xJacky/Nginx-UI, nginx ui (nginxui).
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 1.1%, cao hơn 64.4% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 1.9.10-0.20240126104956-d70e37c8575e, 2.0.0 hoặc mới hơn.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| github.com/0xJacky/Nginx-UI Go | < 1.9.10-0.20240126104956-d70e37c8575emọi phiên bản
| 1.9.10-0.20240126104956-d70e37c8575e
|
| nginx ui | = 2.0.0< 2.0.0
| 2.0.0
|
Mô tả
Summary
Fix bypass to the following bugs
Allowing to inject directly in the app.ini via CRLF to change the value of test_config_cmd and start_cmd resulting in an Authenticated RCE
Impact
Authenticated Remote execution on the host
Mô tả của NVD
Nginx-UI is a web interface to manage Nginx configurations. It is vulnerable to an authenticated arbitrary command execution via CRLF attack when changing the value of test_config_cmd or start_cmd. This vulnerability exists due to an incomplete fix for CVE-2024-22197 and CVE-2024-22198. This vulnerability has been patched in version 2.0.0.beta.12.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí