Tóm tắt nhanh
- CVE-2024-24556 là lỗ hổng mức TRUNG BÌNH (CVSS 6.1) ảnh hưởng urql (nearform), @urql/next.
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 0.36%, cao hơn 29.2% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 1.1.1 hoặc mới hơn.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| urql | < 1.1.1
| 1.1.1
|
| @urql/next npm | < 1.1.1
| 1.1.1
|
Mô tả
impact
The @urql/next package is vulnerable to XSS. To exploit this an attacker would need to ensure that the response returns html tags and that the web-application is using streamed responses (non-RSC). This vulnerability is due to improper escaping of html-like characters in the response-stream.
To fix this vulnerability upgrade to version 1.1.1
Mô tả của NVD
urql is a GraphQL client that exposes a set of helpers for several frameworks. The `@urql/next` package is vulnerable to XSS. To exploit this an attacker would need to ensure that the response returns `html` tags and that the web-application is using streamed responses (non-RSC). This vulnerability is due to improper escaping of html-like characters in the response-stream. To fix this vulnerability upgrade to version 1.1.1
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí