Tóm tắt nhanh
- CVE-2024-24758 là lỗ hổng mức TRUNG BÌNH (CVSS 4.5) ảnh hưởng undici (nodejs), undici.
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 0.77%, cao hơn 55.5% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 6.6.1, 5.28.3 hoặc mới hơn.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| undici | ≥ 6.0.0, < 6.6.1< 5.28.3
| 6.6.15.28.3
|
| undici npm | ≥ 6.0.0, < 6.6.1< 5.28.3
| 6.6.15.28.3
|
Mô tả
Impact
Undici already cleared Authorization headers on cross-origin redirects, but did not clear Proxy-Authorization headers.
Patches
This is patched in v5.28.3 and v6.6.1
Workarounds
There are no known workarounds.
References
Mô tả của NVD
Undici is an HTTP/1.1 client, written from scratch for Node.js. Undici already cleared Authorization headers on cross-origin redirects, but did not clear `Proxy-Authentication` headers. This issue has been patched in versions 5.28.3 and 6.6.1. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí