Tóm tắt nhanh
- CVE-2024-27091 là lỗ hổng mức TRUNG BÌNH (CVSS 6.1) ảnh hưởng geonode, geonode (geosolutionsgroup).
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 0.38%, cao hơn 32.0% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 4.2.3 hoặc mới hơn.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| geonode PyPI | ≥ 3.2.1, < 4.2.3
| 4.2.3
|
| geonode | > 3.2.0, < 4.2.3
| 4.2.3
|
Mô tả
An issue exists within GEONODE where the current rich text editor is vulnerable to Stored XSS. The applications cookies are set securely, but it is possible to retrieve a victims CSRF token and issue a request to change another user's email address to perform a full account takeover. Due to the script element not impacting the CORS policy, requests will succeed.
Mô tả của NVD
GeoNode is a geospatial content management system, a platform for the management and publication of geospatial data. An issue exists within GEONODE where the current rich text editor is vulnerable to Stored XSS. The applications cookies are set securely, but it is possible to retrieve a victims CSRF token and issue a request to change another user's email address to perform a full account takeover. Due to the script element not impacting the CORS policy, requests will succeed. This vulnerability is fixed in 4.2.3.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí