Tóm tắt nhanh
- CVE-2024-29904 là lỗ hổng mức CAO (CVSS 7.5) ảnh hưởng codeigniter4/framework, codeigniter (codeigniter).
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 0.77%, cao hơn 55.7% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 4.4.7 hoặc mới hơn.
Mô tả
Impact
A vulnerability was found in the Language class that allowed DoS attacks. This vulnerability can be exploited by an attacker to consume a large amount of memory on the server.
Patches
Upgrade to v4.4.7 or later. See upgrading guide.
Workarounds
- Disabling Auto Routing prevents a known attack vector in the framework.
- Do not pass invalid values to the
lang() function or Language class.
References
Mô tả của NVD
CodeIgniter is a PHP full-stack web framework A vulnerability was found in the Language class that allowed DoS attacks. This vulnerability can be exploited by an attacker to consume a large amount of memory on the server. Upgrade to v4.4.7 or later.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí