Tóm tắt nhanh
- CVE-2024-31208 là lỗ hổng mức TRUNG BÌNH (CVSS 6.5) ảnh hưởng matrix-synapse, synapse (matrix).
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 1.5%, cao hơn 73.6% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 1.105.1 hoặc mới hơn.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| matrix-synapse PyPI | < 1.105.1
| 1.105.1
|
| synapse | < 1.105.1
| 1.105.1
|
Mô tả
Impact
A remote Matrix user with malicious intent, sharing a room with Synapse instances before 1.105.1, can dispatch specially crafted events to exploit a weakness in how the auth chain cover index is calculated. This can induce high CPU consumption and accumulate excessive data in the database of such instances, resulting in a denial of service.
Servers in private federations, or those that do not federate, are not affected.
Patches
Server administrators should upgrade to 1.105.1 or later.
Workarounds
One can:
- ban the malicious users or ACL block servers from the rooms; and/or
- leave the room and purge the room using the admin API
For more information
If you have any questions or comments about this advisory, please email us at security AT element.io.
Mô tả của NVD
Synapse is an open-source Matrix homeserver. A remote Matrix user with malicious intent, sharing a room with Synapse instances before 1.105.1, can dispatch specially crafted events to exploit a weakness in the V2 state resolution algorithm. This can induce high CPU consumption and accumulate excessive data in the database of such instances, resulting in a denial of service. Servers in private federations, or those that do not federate, are not affected. Server administrators should upgrade to 1.105.1 or later. Some workarounds are available. One can ban the malicious users or ACL block servers from the rooms and/or leave the room and purge the room using the admin API.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí