Tóm tắt nhanh
- CVE-2024-34069 là lỗ hổng mức CAO (CVSS 7.5) ảnh hưởng werkzeug, werkzeug (palletsprojects).
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 3.4%, cao hơn 88.8% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 3.0.3 hoặc mới hơn.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| werkzeug PyPI | < 3.0.3
| 3.0.3
|
| werkzeug | < 3.0.3
| 3.0.3
|
Mô tả
The debugger in affected versions of Werkzeug can allow an attacker to execute code on a developer's machine under some circumstances. This requires the attacker to get the developer to interact with a domain and subdomain they control, and enter the debugger PIN, but if they are successful it allows access to the debugger even if it is only running on localhost. This also requires the attacker to guess a URL in the developer's application that will trigger the debugger.
Mô tả của NVD
Werkzeug is a comprehensive WSGI web application library. The debugger in affected versions of Werkzeug can allow an attacker to execute code on a developer's machine under some circumstances. This requires the attacker to get the developer to interact with a domain and subdomain they control, and enter the debugger PIN, but if they are successful it allows access to the debugger even if it is only running on localhost. This also requires the attacker to guess a URL in the developer's application that will trigger the debugger. This vulnerability is fixed in 3.0.3.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí