Tóm tắt nhanh
- CVE-2024-35228 là lỗ hổng mức TRUNG BÌNH (CVSS 5.5) ảnh hưởng wagtail.
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 0.33%, cao hơn 26.5% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 6.0.5, 6.1.2 hoặc mới hơn.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| wagtail PyPI | ≥ 6.0.0, < 6.0.5≥ 6.1.0, < 6.1.2
| 6.0.56.1.2
|
Mô tả
Impact
Due to an improperly applied permission check in the wagtail.contrib.settings module, a user with access to the Wagtail admin and knowledge of the URL of the edit view for a settings model can access and update that setting, even when they have not been granted permission over the model. The vulnerability is not exploitable by an ordinary site visitor without access to the Wagtail admin.
Patches
Patched versions have been released as Wagtail 6.0.5 and 6.1.2. Wagtail releases prior to 6.0 are unaffected.
Workarounds
No workaround is available.
Acknowledgements
Many thanks to Victor Miti for reporting this issue.
For more information
If you have any questions or comments about this advisory:
Mô tả của NVD
Wagtail is an open source content management system built on Django. Due to an improperly applied permission check in the `wagtail.contrib.settings` module, a user with access to the Wagtail admin and knowledge of the URL of the edit view for a settings model can access and update that setting, even when they have not been granted permission over the model. The vulnerability is not exploitable by an ordinary site visitor without access to the Wagtail admin. Patched versions have been released as Wagtail 6.0.5 and 6.1.2. Wagtail releases prior to 6.0 are unaffected. Users are advised to upgrade. Site owners who are unable to upgrade to a patched version can avoid the vulnerability in `ModelViewSet` by registering the model as a snippet instead. No workaround is available for `wagtail.contrib.settings`.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí