Tóm tắt nhanh
- CVE-2024-37893 là lỗ hổng mức TRUNG BÌNH (CVSS 5.9) ảnh hưởng grumpydictator/firefly-iii.
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 0.59%, cao hơn 48.4% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 6.1.17 hoặc mới hơn.
Mô tả
Impact
A MFA bypass in the Firefly III OAuth flow may allow malicious users to bypass the MFA-check. This allows malicious users to use password spraying to gain access to your Firefly III data using passwords stolen from other sources. As OAuth applications are easily enumerable using an incrementing id, an attacker could try sign an OAuth application up to a users profile quite easily if they have created one. The attacker would also need to know the victims username and password.
Patches
Problem has been patched in Firefly III v6.1.17 and up.
Workarounds
- Use a unique password for your Firefly III instance,
- Store your password securely, i.e. in a password manager or in your head.
References
Mô tả của NVD
Firefly III is a free and open source personal finance manager. In affected versions an MFA bypass in the Firefly III OAuth flow may allow malicious users to bypass the MFA-check. This allows malicious users to use password spraying to gain access to Firefly III data using passwords stolen from other sources. As OAuth applications are easily enumerable using an incrementing id, an attacker could try sign an OAuth application up to a users profile quite easily if they have created one. The attacker would also need to know the victims username and password. This problem has been patched in Firefly III v6.1.17 and up. Users are advised to upgrade. Users unable to upgrade should Use a unique password for their Firefly III instance and store their password securely, i.e. in a password manager.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí