Tóm tắt nhanh
- CVE-2024-3829 là lỗ hổng mức NGHIÊM TRỌNG (CVSS 9.1) ảnh hưởng qdrant-client, qdrant (qdrant).
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 0.91%, cao hơn 60.1% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 1.9.0 hoặc mới hơn.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| qdrant-client PyPI | < 1.9.0
| 1.9.0
|
| qdrant | < 1.9.0
| 1.9.0
|
Mô tả
qdrant/qdrant version 1.9.0-dev is vulnerable to arbitrary file read and write during the snapshot recovery process. Attackers can exploit this vulnerability by manipulating snapshot files to include symlinks, leading to arbitrary file read by adding a symlink that points to a desired file on the filesystem and arbitrary file write by including a symlink and a payload file in the snapshot's directory structure. This vulnerability allows for the reading and writing of arbitrary files on the server, which could potentially lead to a full takeover of the system. The issue is fixed in version v1.9.0.
Mô tả của NVD
qdrant/qdrant version 1.9.0-dev is vulnerable to arbitrary file read and write during the snapshot recovery process. Attackers can exploit this vulnerability by manipulating snapshot files to include symlinks, leading to arbitrary file read by adding a symlink that points to a desired file on the filesystem and arbitrary file write by including a symlink and a payload file in the snapshot's directory structure. This vulnerability allows for the reading and writing of arbitrary files on the server, which could potentially lead to a full takeover of the system. The issue is fixed in version v1.9.0.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí