Tóm tắt nhanh
- CVE-2024-42473 là lỗ hổng mức NGHIÊM TRỌNG (CVSS 9.8) ảnh hưởng github.com/openfga/openfga, openfga (openfga).
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 0.53%, cao hơn 44.6% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 1.5.9 hoặc mới hơn.
Mô tả
Overview
OpenFGA v1.5.7 and v1.5.8 are vulnerable to authorization bypass when calling Check API with a model that uses but not and from expressions and a userset.
Fix
- If you are using OpenFGA within Docker or as a Go library, as a binary, or through Docker, upgrade to v1.5.9 as soon as possible
- If using Helm chart, upgrade to 0.2.12 as soon as possible.
This fix is backward compatible.
Mô tả của NVD
OpenFGA is an authorization/permission engine. OpenFGA v1.5.7 and v1.5.8 are vulnerable to authorization bypass when calling Check API with a model that uses `but not` and `from` expressions and a userset. Users should downgrade to v1.5.6 as soon as possible. This downgrade is backward compatible. As of time of publication, a patch is not available but OpenFGA's maintainers are planning a patch for inclusion in a future release.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí