Tóm tắt nhanh
- CVE-2024-47888 là lỗ hổng mức TRUNG BÌNH (CVSS 6.6) ảnh hưởng actiontext.
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 0.98%, cao hơn 62.4% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 6.1.7.9, 7.0.8.5, 7.1.4.1, 7.2.1.1 hoặc mới hơn.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| actiontext RubyGems | ≥ 6.0.0, < 6.1.7.9≥ 7.0.0, < 7.0.8.5≥ 7.1.0, < 7.1.4.1≥ 7.2.0, < 7.2.1.1
| 6.1.7.97.0.8.57.1.4.17.2.1.1
|
Mô tả
There is a possible ReDoS vulnerability in the plain_text_for_blockquote_node helper in Action Text. This vulnerability has been assigned the CVE identifier CVE-2024-47888.
Impact
Carefully crafted text can cause the plain_text_for_blockquote_node helper to take an unexpected amount of time, possibly resulting in a DoS vulnerability. All users running an affected release should either upgrade or apply the relevant patch immediately.
Ruby 3.2 has mitigations for this problem, so Rails applications using Ruby 3.2 or newer are unaffected. Rails 8.0.0.beta1 depends on Ruby 3.2 or greater so is unaffected.
Releases
The fixed releases are available at the normal locations.
Workarounds
Users can avoid calling plain_text_for_blockquote_node or upgrade to Ruby 3.2
Credits
Thanks to ooooooo_q for the report!
Mô tả của NVD
Action Text brings rich text content and editing to Rails. Starting in version 6.0.0 and prior to versions 6.1.7.9, 7.0.8.5, 7.1.4.1, and 7.2.1.1, there is a possible ReDoS vulnerability in the `plain_text_for_blockquote_node helper` in Action Text. Carefully crafted text can cause the `plain_text_for_blockquote_node` helper to take an unexpected amount of time, possibly resulting in a DoS vulnerability. All users running an affected release should either upgrade to versions 6.1.7.9, 7.0.8.5, 7.1.4.1, or 7.2.1.1 or apply the relevant patch immediately. As a workaround, users can avoid calling `plain_text_for_blockquote_node` or upgrade to Ruby 3.2. Ruby 3.2 has mitigations for this problem, so Rails applications using Ruby 3.2 or newer are unaffected. Rails 8.0.0.beta1 depends on Ruby 3.2 or greater so is unaffected.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí