Tóm tắt nhanh
- CVE-2024-48911 là lỗ hổng mức CAO (CVSS 7.8) ảnh hưởng opencanary, opencanary (thinkst).
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 0.22%, cao hơn 12.9% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 0.9.4, 0.9.5 hoặc mới hơn.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| opencanary PyPI | < 0.9.4< 0.9.5
| 0.9.40.9.5
|
| opencanary | < 0.9.4
| 0.9.4
|
Mô tả
Impact
OpenCanary directly executed commands taken from its config file. Where the config file is stored in an unprivileged user directory but the daemon is executed by root, it’s possible for the unprivileged user to change the config file and escalate permissions when root later runs the daemon.
Thanks to the folks at Whirlylabs for finding and fixing this.
Patches
Upgrade to 0.9.4 or higher.
Mô tả của NVD
OpenCanary, a multi-protocol network honeypot, directly executed commands taken from its config file. Prior to version 0.9.4, where the config file is stored in an unprivileged user directory but the daemon is executed by root, it’s possible for the unprivileged user to change the config file and escalate permissions when root later runs the daemon. Version 0.9.4 contains a fix for the issue.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí