Tóm tắt nhanh
- CVE-2024-51479 là lỗ hổng mức CAO (CVSS 7.5) ảnh hưởng next.js (vercel), next.
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 4.0%, cao hơn 90.5% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 14.2.15 hoặc mới hơn.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| next.js | ≥ 9.5.5, < 14.2.15
| 14.2.15
|
| next npm | ≥ 9.5.5, < 14.2.15
| 14.2.15
|
Mô tả
Impact
If a Next.js application is performing authorization in middleware based on pathname, it was possible for this authorization to be bypassed.
Patches
This issue was patched in Next.js 14.2.15 and later.
If your Next.js application is hosted on Vercel, this vulnerability has been automatically mitigated, regardless of Next.js version.
Workarounds
There are no official workarounds for this vulnerability.
Credits
We'd like to thank tyage (GMO CyberSecurity by IERAE) for responsible disclosure of this issue.
Mô tả của NVD
Next.js is a React framework for building full-stack web applications. In affected versions if a Next.js application is performing authorization in middleware based on pathname, it was possible for this authorization to be bypassed for pages directly under the application's root directory. For example: * [Not affected] `https://example.com/` * [Affected] `https://example.com/foo` * [Not affected] `https://example.com/foo/bar`. This issue is patched in Next.js `14.2.15` and later. If your Next.js application is hosted on Vercel, this vulnerability has been automatically mitigated, regardless of Next.js version. There are no official workarounds for this vulnerability.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí