Tóm tắt nhanh
- CVE-2024-55890 là lỗ hổng mức TRUNG BÌNH (CVSS 6.9) ảnh hưởng dtale.
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 2.4%, cao hơn 84.2% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 3.16.1 hoặc mới hơn.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| dtale PyPI | < 3.16.1
| 3.16.1
|
Mô tả
Impact
Users hosting D-Tale publicly can be vulnerable to remote code execution allowing attackers to run malicious code on the server.
Patches
Users should upgrade to version 3.16.1 where the update-settings endpoint blocks the ability for users to update the enable_custom_filters flag. You can find out more information on how to turn that flag on here
Workarounds
The only workaround for versions earlier than 3.16.1 is to only host D-Tale to trusted users.
References
See "Custom Filter" documentation
Mô tả của NVD
D-Tale is a visualizer for pandas data structures. Prior to version 3.16.1, users hosting D-Tale publicly can be vulnerable to remote code execution allowing attackers to run malicious code on the server. Users should upgrade to version 3.16.1 where the `update-settings` endpoint blocks the ability for users to update the `enable_custom_filters` flag. The only workaround for versions earlier than 3.16.1 is to only host D-Tale to trusted users.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí