Tóm tắt nhanh
- CVE-2024-56201 là lỗ hổng mức CAO (CVSS 8.8) ảnh hưởng jinja2, jinja (palletsprojects).
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 0.31%, cao hơn 23.5% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 3.1.5 hoặc mới hơn.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| jinja2 PyPI | ≥ 3.0.0, < 3.1.5
| 3.1.5
|
| jinja | ≥ 3.0.0, < 3.1.5
| 3.1.5
|
Mô tả
A bug in the Jinja compiler allows an attacker that controls both the content and filename of a template to execute arbitrary Python code, regardless of if Jinja's sandbox is used.
To exploit the vulnerability, an attacker needs to control both the filename and the contents of a template. Whether that is the case depends on the type of application using Jinja. This vulnerability impacts users of applications which execute untrusted templates where the template author can also choose the template filename.
Mô tả của NVD
Jinja is an extensible templating engine. In versions on the 3.x branch prior to 3.1.5, a bug in the Jinja compiler allows an attacker that controls both the content and filename of a template to execute arbitrary Python code, regardless of if Jinja's sandbox is used. To exploit the vulnerability, an attacker needs to control both the filename and the contents of a template. Whether that is the case depends on the type of application using Jinja. This vulnerability impacts users of applications which execute untrusted templates where the template author can also choose the template filename. This vulnerability is fixed in 3.1.5.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí